installing problem, mod_rewrite, cache or webserver??

me_sol's Avatar

me_sol

08 Nov, 2012 07:42 PM

Hi,

I've been reading a lot of discussions here on problems concerning the install. And my problem seems a lot of what Stefano describes here: http://forum.fork-cms.com/discussions/general/137-what-is-wrong

I installed Fork, it works, but I don't seem to get .css for the backend.
(I've emtied the cache, the backend cache, made sure the .htaccess is in place, deleted the lines)

I've contacted my webhost about the mod_rewrite (because I got this error while installing:
warning mod_rewrite
Fork CMS will not be able to run if mod_rewrite can not be applied. Please make sure that the .htaccess file is present (the file starts with a dot, so it may be hidden on your filesystem), being read (AllowOverride directive) and the mod_rewrite module is enabled in Apache. If you are installing Fork CMS on another webserver than Apache, make sure you have manually configured your webserver to properly rewrite urls. More information can be found in ourknowledge base. If you are certain that your server is well configured, you may proceed the installation despite this warning.

Webhost is saying this: De module Mod_rewrite is echter standaard geactiveerd op uw webhosting pakket en gebruikt u door middel van een .htaccess-bestand. Veel Content Management Systemen maken dit bestand voor u aan na het inschakelen van permalinks of url-rewrites. (English: Mod_rewrite is always activated)

And they suggest that I: Ziet u na het uploaden van het .htaccess-bestand naar de server de wijzigingen niet? Het synchroniseren van het .htaccess-bestand met de server zal het probleem mogelijk oplossen. (English: I have to manually sync the .htaccess file)

Ofcourse, this doesn't help either.

The last thing I didn't try was the solution that helped for Stefano, because I cannot find the Path of apache server in the step2.php ? Because it's not there? Warning: I am no expert in .php nor server technology, so be gentle on me while explaining in these matters :-)

Can someone help me with this? It would be Highly Appreciated!!

Oh ja, everytime I access my backend, en try to change things, I get 100 error e-mails sent. screenshot attached. I don't understand much of these...

  1. Support Staff 1 Posted by tijs on 09 Nov, 2012 07:14 AM

    tijs's Avatar

    Can you make a screenshot of your FTP-program which shows the directory listing and the .htaccess file?
    Which hosting provider do you use?

  2. 2 Posted by me_sol on 09 Nov, 2012 07:21 AM

    me_sol's Avatar

    Hi Tijs,

    please see attached file.

    I also just discovered a second .htaccess file, that I cannot change, rename, or delete. And it's located in the directory /webspace. Could this be the reason? Can the two .htaccess files intervene eachother?

    Hosting provider = hostnet.nl

    Thanks in advance for yr trouble!

  3. Support Staff 3 Posted by tijs on 09 Nov, 2012 07:24 AM

    tijs's Avatar

    Can you show the rights for the .htacces-file?
    Do you have access to the error-logs? Probably in the log-folder

  4. 4 Posted by me_sol on 09 Nov, 2012 07:26 AM

    me_sol's Avatar

    do I upload the log.php?

    How do I show you the rights of the ht.access file?

  5. Support Staff 5 Posted by tijs on 09 Nov, 2012 07:30 AM

    tijs's Avatar

    No, check the content of the folder "log" (shown in your screenshot)
    The permissions/rights are in the column "rechten" but they aren't visible in the screenshot.

  6. 6 Posted by me_sol on 09 Nov, 2012 07:34 AM

    me_sol's Avatar

    rights say: adfrw(0644)
    (second .htaccess file in /webspace directory says : 0440)

    And I can't see the contents of the log folder " Fout: Ontvangen van mappenlijst is mislukt", i don't seem to have access

  7. Support Staff 7 Posted by tijs on 09 Nov, 2012 07:36 AM

    tijs's Avatar

    Can you ask your host for the logfiles?

  8. 8 Posted by me_sol on 09 Nov, 2012 07:41 AM

    me_sol's Avatar

    I will, thanks so far!

  9. 9 Posted by me_sol on 09 Nov, 2012 06:05 PM

    me_sol's Avatar

    Now working in debug mode, and it works fine... I saw this on the forum as well a couple of times...

    I will have to wait till after the weekend for the logfiles I'm guessing :-(

  10. 10 Posted by me_sol on 30 Nov, 2012 09:59 AM

    me_sol's Avatar

    Hi Tijs,

    Finally i have the log files, there is not much info their.. Or at least nothing I understand...

    Does this clarify anything for you?

  11. Support Staff 11 Posted by tijs on 28 Dec, 2012 07:04 AM

    tijs's Avatar

    Try to remove "Options +FollowSymlinks -Indexes" from the .htaccess-file

  12. 12 Posted by me_sol on 28 Dec, 2012 08:46 AM

    me_sol's Avatar

    I removed it, but it didn't work...

  13. Support Staff 13 Posted by tijs on 09 Jan, 2013 10:32 PM

    tijs's Avatar

    Then you will have to ask for the logs again.

  14. 14 Posted by Peter Muusers on 01 Feb, 2013 11:41 AM

    Peter Muusers's Avatar

    I'm having the same issue on a ForkCMS site on hostnet. It seems like the minifier is not working correctly.

    The minifier is turned off in debug_mode, that's why everything is ok. Ofcourse, this is no good for running a site in production (with no-follow, and no-cache on all pages).

    I've bypassed the minifier by turning it off in the code, but running into performance problems now. Not sure if that's because of the lack of using the minifier, or this is just a bad hosting environment.

  15. Support Staff 15 Posted by tijs on 01 Feb, 2013 12:19 PM

    tijs's Avatar

    Peter: any chance you can provide the server-logs?

  16. 16 Posted by giretti on 28 Jun, 2013 02:19 PM

    giretti's Avatar

    well he didn't but I can if it helps.

    I have the same issue (I am on hostnet too)


    Free hosting

  17. 17 Posted by Luciferbui on 13 Sep, 2015 12:20 AM

    Luciferbui's Avatar

    Mysite is same trouble http://bizzaviet.com :( Can anybody help me?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • help.JPG 53.6 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac