Forkcms 4.5.4 on Windows Server 2016, IIS 10 nad PHP 7.1.7

aattaxx's Avatar

aattaxx

07 Jul, 2017 08:13 AM

Hi, I am trying to run Fork CMS on a Windows Server 2016 / IIS 10.0.14393.0 and PHP version 7.1.7.

Unfortunately, the first steps have already failed.

My steps:

  1. Fork CMS 4.5.4 downloaded

  2. Fork CMS unpacked under the path: C:\inetpub\wwwroot\fork

  3. New website created in IIS

  4. Site name: fork

  5. Application pool: DefaultAppPool

  6. Physical path: C: \ inetpub \ wwwroot \ fork

  7. Explorer the physical path via IIS

  8. (works)

  9. Open Firefox and go to "localhost/fork"

  10. Firefox is trying to load "http://localhost/install"

  11. Receive error:
    -HTTP Error 404.0 - Not Found

Detailed Error Information:
Module: IIS Web Core
Notification: MapRequestHandler
Handler: StaticFile
Error Code: 0x80070002
Requested URL: http://localhost:80/install
Physical Path: C:\inetpub\wwwroot\install
Logon Method: Anonymous
Logon User: Anonymous

Is there someone, who has perhaps the same problem and found a solution?

Thanks in advance!

  1. 1 Posted by Koen on 07 Jul, 2017 08:22 AM

    Koen's Avatar

    Hey AaTTaxX,

    My first guess is that you're trying to install Fork CMS in a subdirectory (/fork), which isn't allowed. It should live in the your root dir, in your case: C:\inetpub\wwwroot.

  2. 2 Posted by aattaxx on 07 Jul, 2017 09:16 AM

    aattaxx's Avatar

    Hi Koen,

    yes you're right, have tried to install in a subdirectory.
    Now, just tried to install in my root directory but receive the same error.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • fork.png 44.3 KB
  • fork2.png 71.6 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac