Problem with location Module

koray's Avatar

koray

17 Oct, 2012 07:25 AM

In the beginning there wasn't any problem and the map displayed correctly on my page.
But now it is gone.. I've tried creating a new location adress and adding this to the page, but nothing happened.

In the javascript console I can see two things:

1a5f057824c39b32a1c9f7354070dc50.js:1 SyntaxError: Unexpected token ':'
location.js:20 ReferenceError: Can't find variable: google

Please help me. Thank you!
(if you would like to see it for yourself -> http://sushicorner.be/over-ons )

  1. Support Staff 1 Posted by tijs on 11 Nov, 2012 12:01 PM

    tijs's Avatar

    Which version of Fork are you using?

  2. 2 Posted by koray on 14 Nov, 2012 01:08 PM

    koray's Avatar

    I am using 3.4.2 (2012-07-31)

    have you got any ideas?

  3. 3 Posted by jeroendesloover... on 15 Nov, 2012 07:13 AM

    jeroendesloovere's Avatar

    Hi there, I had this problem also!

    The problem occurs when Debug = false;

    Easy to solve in location v2.0.0,
    open "frontend/modules/location/widgets/location.php"

    In the execute function, place the rule (it might be different then yours, copy it)

    $this->addJS('http://maps.google.com/maps/api/js?sensor=true', true, false);
    

    above

    parent::execute();
    

    Set debugging to true, and check it out.
    Then set debugging to false and it should work now.

    Can you verify?

  4. 4 Posted by koray on 15 Nov, 2012 07:47 AM

    koray's Avatar

    @jeroendesloovere Thank you so much!!
    actually i saw the line in the location.php AFTER parent::execute();
    I copied yours to right above the execute statement and hooray! It Worked!

  5. 5 Posted by jeroendesloover... on 28 Nov, 2012 02:03 PM

    jeroendesloovere's Avatar

    This discussion can be closed.
    Bugfix #336 should be integraded in Fork CMS soon...

  6. tijs closed this discussion on 28 Dec, 2012 07:06 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac